$re = '/xxx(?!(.*STRING1.*))xxx/mi';
$str = 'xxxxxx
xxxSTRING1xxx
xxxSTRING2xxx
xxxSTRING3xxx
import org.apache.spark.rdd.RDD
df.rdd
.map
df.rdd.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);