#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ffLoyalty\.displayPoints(.|\s)*?"
Local $sString = "<script type="text/javascript">_ffLoyalty.initialize("unBnQKehY2q3W7u"); _ffLoyalty.displayPoints({price : "64.99", calculate: "true", product_id: "TMUGLER-4715105", categories: "TMUGLER-4715105,211942", brands: "Thierry Mugler", tags: "TMUGLER-4715105,211942"});</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")