$re = '/ffLoyalty\.displayPoints(.|\s)*?/';
$str = '<script type="text/javascript">_ffLoyalty.initialize("unBnQKehY2q3W7u"); _ffLoyalty.displayPoints({price : "64.99", calculate: "true", product_id: "TMUGLER-4715105", categories: "TMUGLER-4715105,211942", brands: "Thierry Mugler", tags: "TMUGLER-4715105,211942"});</script>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);