import re
regex = re.compile(r"ffLoyalty\.displayPoints(.|\s)*?")
test_str = "<script type=\"text/javascript\">_ffLoyalty.initialize(\"unBnQKehY2q3W7u\"); _ffLoyalty.displayPoints({price : \"64.99\", calculate: \"true\", product_id: \"TMUGLER-4715105\", categories: \"TMUGLER-4715105,211942\", brands: \"Thierry Mugler\", tags: \"TMUGLER-4715105,211942\"});</script>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")