using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ffLoyalty\.displayPoints(.|\s)*?";
string input = @"<script type=""text/javascript"">_ffLoyalty.initialize(""unBnQKehY2q3W7u""); _ffLoyalty.displayPoints({price : ""64.99"", calculate: ""true"", product_id: ""TMUGLER-4715105"", categories: ""TMUGLER-4715105,211942"", brands: ""Thierry Mugler"", tags: ""TMUGLER-4715105,211942""});</script>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}