import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ffLoyalty\\.displayPoints(.|\\s)*?";
final String string = "<script type=\"text/javascript\">_ffLoyalty.initialize(\"unBnQKehY2q3W7u\"); _ffLoyalty.displayPoints({price : \"64.99\", calculate: \"true\", product_id: \"TMUGLER-4715105\", categories: \"TMUGLER-4715105,211942\", brands: \"Thierry Mugler\", tags: \"TMUGLER-4715105,211942\"});</script>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}