import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?1920x1200.*$(*SKIP)(*F)|(?:\\d+[a-z]|[a-z]+\\d)[a-z\\d]*";
final String string = "group1:\n"
+ "2aa\n"
+ "a2\n"
+ "2aaaaaa\n"
+ "aaaa2\n"
+ "aaa2aaaa\n"
+ "2222a2222-2222-aaaa\n"
+ "sdfzugsdufz-aaaaa7-7aaaa\n"
+ "sdfz/////...ugsd33ufz_//__-aaaaa7__///-7aaaa\n\n"
+ "group-two:\n"
+ "aaaaaa\n"
+ "22222\n"
+ "aaa-222-aaa-aaa\n"
+ "aaaaa222aaa1920x1200bbbbb1234556789\n"
+ "aaa1920x1200-\n"
+ "aaaaf344t---1920x1200aaa------\n"
+ "aaaaaaaaaaaaaaaaa-1920x1200\n"
+ "aa456456a-1920x1200-dfgfdg656dfg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}