re = /.*?1920x1200.*$(*SKIP)(*F)|(?:\d+[a-z]|[a-z]+\d)[a-z\d]*/im
str = 'group1:
2aa
a2
2aaaaaa
aaaa2
aaa2aaaa
2222a2222-2222-aaaa
sdfzugsdufz-aaaaa7-7aaaa
sdfz/////...ugsd33ufz_//__-aaaaa7__///-7aaaa
group-two:
aaaaaa
22222
aaa-222-aaa-aaa
aaaaa222aaa1920x1200bbbbb1234556789
aaa1920x1200-
aaaaf344t---1920x1200aaa------
aaaaaaaaaaaaaaaaa-1920x1200
aa456456a-1920x1200-dfgfdg656dfg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end