// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im).*?1920x1200.*$(*SKIP)(*F)|(?:\d+[a-z]|[a-z]+\d)[a-z\d]*").unwrap();
let string = "group1:
2aa
a2
2aaaaaa
aaaa2
aaa2aaaa
2222a2222-2222-aaaa
sdfzugsdufz-aaaaa7-7aaaa
sdfz/////...ugsd33ufz_//__-aaaaa7__///-7aaaa
group-two:
aaaaaa
22222
aaa-222-aaa-aaa
aaaaa222aaa1920x1200bbbbb1234556789
aaa1920x1200-
aaaaf344t---1920x1200aaa------
aaaaaaaaaaaaaaaaa-1920x1200
aa456456a-1920x1200-dfgfdg656dfg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}