import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "datetime=\"(.*?)\"";
final String string = "[<time pubdate class=\"dt-updated\" datetime=\"2015-07-09T11:50:32+0000\" title=\"Time posted: 09 Jul 2015, 11:50:32 (UTC)\" aria-label=\"Posted on 09 Jul\">09 Jul</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T13:59:49+0000\" title=\"Time posted: 18 Jun 2015, 13:59:49 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T12:56:47+0000\" title=\"Time posted: 18 Jun 2015, 12:56:47 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T12:41:42+0000\" title=\"Time posted: 18 Jun 2015, 12:41:42 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}