// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)datetime="(.*?)""#).unwrap();
let string = "[<time pubdate class=\"dt-updated\" datetime=\"2015-07-09T11:50:32+0000\" title=\"Time posted: 09 Jul 2015, 11:50:32 (UTC)\" aria-label=\"Posted on 09 Jul\">09 Jul</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T13:59:49+0000\" title=\"Time posted: 18 Jun 2015, 13:59:49 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T12:56:47+0000\" title=\"Time posted: 18 Jun 2015, 12:56:47 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T12:41:42+0000\" title=\"Time posted: 18 Jun 2015, 12:41:42 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}