use strict;
my $str = '[<time pubdate class="dt-updated" datetime="2015-07-09T11:50:32+0000" title="Time posted: 09 Jul 2015, 11:50:32 (UTC)" aria-label="Posted on 09 Jul">09 Jul</time>, <time pubdate class="dt-updated" datetime="2015-06-18T13:59:49+0000" title="Time posted: 18 Jun 2015, 13:59:49 (UTC)" aria-label="Posted on 18 Jun">18 Jun</time>, <time pubdate class="dt-updated" datetime="2015-06-18T12:56:47+0000" title="Time posted: 18 Jun 2015, 12:56:47 (UTC)" aria-label="Posted on 18 Jun">18 Jun</time>, <time pubdate class="dt-updated" datetime="2015-06-18T12:41:42+0000" title="Time posted: 18 Jun 2015, 12:41:42 (UTC)" aria-label="Posted on 18 Jun">18 Jun</time>]';
my $regex = qr/datetime="(.*?)"/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}