import re
regex = re.compile(r"datetime=\"(.*?)\"", flags=re.IGNORECASE)
test_str = "[<time pubdate class=\"dt-updated\" datetime=\"2015-07-09T11:50:32+0000\" title=\"Time posted: 09 Jul 2015, 11:50:32 (UTC)\" aria-label=\"Posted on 09 Jul\">09 Jul</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T13:59:49+0000\" title=\"Time posted: 18 Jun 2015, 13:59:49 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T12:56:47+0000\" title=\"Time posted: 18 Jun 2015, 12:56:47 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>, <time pubdate class=\"dt-updated\" datetime=\"2015-06-18T12:41:42+0000\" title=\"Time posted: 18 Jun 2015, 12:41:42 (UTC)\" aria-label=\"Posted on 18 Jun\">18 Jun</time>]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")