import Foundation
let pattern = #"datetime="(.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"[<time pubdate class="dt-updated" datetime="2015-07-09T11:50:32+0000" title="Time posted: 09 Jul 2015, 11:50:32 (UTC)" aria-label="Posted on 09 Jul">09 Jul</time>, <time pubdate class="dt-updated" datetime="2015-06-18T13:59:49+0000" title="Time posted: 18 Jun 2015, 13:59:49 (UTC)" aria-label="Posted on 18 Jun">18 Jun</time>, <time pubdate class="dt-updated" datetime="2015-06-18T12:56:47+0000" title="Time posted: 18 Jun 2015, 12:56:47 (UTC)" aria-label="Posted on 18 Jun">18 Jun</time>, <time pubdate class="dt-updated" datetime="2015-06-18T12:41:42+0000" title="Time posted: 18 Jun 2015, 12:41:42 (UTC)" aria-label="Posted on 18 Jun">18 Jun</time>]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)