# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=file\s).*?(?=\s*>)/$0 xml:space="preserve"/;t' <<< " <file datatype=\"plaintext\" original=\"question1.html\" source-language=\"eng-ZZZ\" target-language=\"rus-EST\">"