const regex = /(?<=file\s).*?(?=\s*>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=file\\s).*?(?=\\s*>)', '')
const str = ` <file datatype="plaintext" original="question1.html" source-language="eng-ZZZ" target-language="rus-EST">`;
const subst = `$0 xml:space="preserve"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);