re = /(?<=file\s).*?(?=\s*>)/
str = ' <file datatype="plaintext" original="question1.html" source-language="eng-ZZZ" target-language="rus-EST">'
subst = '$0 xml:space="preserve"'
result = str.sub(re, subst)
# Print the result of the substitution
puts result