use strict;
my $str = ' <file datatype="plaintext" original="question1.html" source-language="eng-ZZZ" target-language="rus-EST">';
my $regex = qr/(?<=file\s).*?(?=\s*>)/p;
my $subst = '$0 xml:space="preserve"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";