using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/(?<a>[^\']+)'\sContent";
string input = @" 2018-11-26 05:27:57,330 [http-nio-228.0.0.1-80-exec-653] [INFO ] (o.a.e.UploadServiceImpl:360) - Deploy to 'raven-snapshots:com/mayhem/xmen/edm-aggregator/1.0.0-SNAPSHOT/edm-aggregator-1.0.0-SNAPSHOT.rom' Content-Length: 710
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}