import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/(?<a>[^\\']+)'\\sContent";
final String string = " 2018-11-26 05:27:57,330 [http-nio-228.0.0.1-80-exec-653] [INFO ] (o.a.e.UploadServiceImpl:360) - Deploy to 'raven-snapshots:com/mayhem/xmen/edm-aggregator/1.0.0-SNAPSHOT/edm-aggregator-1.0.0-SNAPSHOT.rom' Content-Length: 710\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}