// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\/(?<a>[^\']+)'\sContent").unwrap();
let string = " 2018-11-26 05:27:57,330 [http-nio-228.0.0.1-80-exec-653] [INFO ] (o.a.e.UploadServiceImpl:360) - Deploy to 'raven-snapshots:com/mayhem/xmen/edm-aggregator/1.0.0-SNAPSHOT/edm-aggregator-1.0.0-SNAPSHOT.rom' Content-Length: 710
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}