using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{4}-[0-9]{2}-[0-9]{2}\/(.*?)\/";
string input = @"https://www.example.com/news/2017-08-09/hello-world/topics/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}