package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]{4}-[0-9]{2}-[0-9]{2}\/(.*?)\/`)
var str = `https://www.example.com/news/2017-08-09/hello-world/topics/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}