// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[0-9]{4}-[0-9]{2}-[0-9]{2}\/(.*?)\/").unwrap();
let string = "https://www.example.com/news/2017-08-09/hello-world/topics/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}