re = /[0-9]{4}-[0-9]{2}-[0-9]{2}\/(.*?)\//
str = 'https://www.example.com/news/2017-08-09/hello-world/topics/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end