#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "a(b.+)?z"
Local $sString = "az" & @CRLF & _
"abz" & @CRLF & _
"abcz" & @CRLF & _
""
Local $sSubst = "a:$1z"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)