use strict;
my $str = 'az
abz
abcz
';
my $regex = qr/a(b.+)?z/p;
my $subst = 'a:$1z';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";