import Foundation
let pattern = #"a(b.+)?z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
az
abz
abcz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"a:$1z"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)