using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a(b.+)?z";
string substitution = @"a:$1z";
string input = @"az
abz
abcz
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}