using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:[^""]*""[^""]*"")*[^""]*$)(,)(.*?,|)(?=.*?(?:,|$))";
string substitution = @":$2";
string input = @"""name"", ""bob"", ""hello, world"", true, ""name"", ""bob"", ""number"", 16, ""place"", ""somewhere"" ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}