import Foundation
let pattern = #"(?=(?:[^"]*"[^"]*")*[^"]*$)(,)(.*?,|)(?=.*?(?:,|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""name", "bob", "hello, world", true, "name", "bob", "number", 16, "place", "somewhere" "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)