const regex = /(?=(?:[^"]*"[^"]*")*[^"]*$)(,)(.*?,|)(?=.*?(?:,|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:[^"]*"[^"]*")*[^"]*$)(,)(.*?,|)(?=.*?(?:,|$))', 'g')
const str = `"name", "bob", "hello, world", true, "name", "bob", "number", 16, "place", "somewhere" `;
const subst = `:$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);