$re = '/(?=(?:[^"]*"[^"]*")*[^"]*$)(,)(.*?,|)(?=.*?(?:,|$))/';
$str = '"name", "bob", "hello, world", true, "name", "bob", "number", 16, "place", "somewhere" ';
$subst = ":$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;