use strict;
my $str = '"name", "bob", "hello, world", true, "name", "bob", "number", 16, "place", "somewhere" ';
my $regex = qr/(?=(?:[^"]*"[^"]*")*[^"]*$)(,)(.*?,|)(?=.*?(?:,|$))/p;
my $subst = ':$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";