#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[A-Z\d]+$"
Local $sString = "test" & @CRLF & _
"Test23" & @CRLF & _
"234!" & @CRLF & _
"asdf#@$(" & @CRLF & _
"test onetwo" & @CRLF & _
"asdf" & @CRLF & _
"onetwo123three"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")