re = /^[A-Z\d]+$/im
str = 'test
Test23
234!
asdf#@$(
test onetwo
asdf
onetwo123three'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end