$re = '/^[A-Z\d]+$/im';
$str = 'test
Test23
234!
asdf#@$(
test onetwo
asdf
onetwo123three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);