import re
regex = re.compile(r"^[A-Z\d]+$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("test\n"
"Test23\n"
"234!\n"
"asdf#@$(\n"
"test onetwo\n"
"asdf\n"
"onetwo123three")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")