package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)Anchor:(?<extact>.*)(A\/C)`)
var str = `Anchor: This is the text I want to extract A/C : 2015-5-20
Anchor: This is the text I want to extract
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}