$re = '/Anchor:(?<extact>.*)(A\/C)/im';
$str = 'Anchor: This is the text I want to extract A/C : 2015-5-20
Anchor: This is the text I want to extract
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);