re = /Anchor:(?<extact>.*)(A\/C)/im
str = 'Anchor: This is the text I want to extract A/C : 2015-5-20
Anchor: This is the text I want to extract
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end