// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)Anchor:(?<extact>.*)(A\/C)").unwrap();
let string = "Anchor: This is the text I want to extract A/C : 2015-5-20
Anchor: This is the text I want to extract
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}