const regex = /Anchor:(?<extact>.*)(A\/C)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Anchor:(?<extact>.*)(A\\\/C)', 'gim')
const str = `Anchor: This is the text I want to extract A/C : 2015-5-20
Anchor: This is the text I want to extract
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}