#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)orareview"
Local $sString = "/* Comment type1 */" & @CRLF & _
"The URL for the code review for this transaction is" & @CRLF & _
"https://orareview.us.oracle.com/113050117" & @CRLF & _
"http://orareview.com" & @CRLF & _
"123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")