package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)orareview`)
var str = `/* Comment type1 */
The URL for the code review for this transaction is
https://orareview.us.oracle.com/113050117
http://orareview.com
123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}