re = /orareview/
str = '/* Comment type1 */
The URL for the code review for this transaction is
https://orareview.us.oracle.com/113050117
http://orareview.com
123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end