// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)orareview").unwrap();
let string = "/* Comment type1 */
The URL for the code review for this transaction is
https://orareview.us.oracle.com/113050117
http://orareview.com
123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}