import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "orareview";
final String string = "/* Comment type1 */\n"
+ "The URL for the code review for this transaction is\n"
+ "https://orareview.us.oracle.com/113050117\n"
+ "http://orareview.com\n"
+ "123";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}