using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((http|https)\:\/\/|)([\w|\-]+\.)+\w+($|[\w\-\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)";
string input = @"http://www3.hilton.com/en/hotels
http://www3.hilt-on.com/en/hot-els/unite
http://www3.hilton.com/en/hotels/united-kingdom/the-waldorf-hilton-london-LONWAHI/index.html";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}