$re = '/^((http|https)\:\/\/|)([\w|\-]+\.)+\w+($|[\w\-\/\.]+$|[\w\/\.]+\?[\w\=\&\.]+$)/mi';
$str = 'http://www3.hilton.com/en/hotels
http://www3.hilt-on.com/en/hot-els/unite
http://www3.hilton.com/en/hotels/united-kingdom/the-waldorf-hilton-london-LONWAHI/index.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);